FIXED: Flannel CNI plugin. Error

Question

Flannel CNI plugin. Error: [plugin flannel does not support config version “”]

kubelet[15750]: W0921 20:39:34.109650   15750 cni.go:202] Error validating CNI config ...: [plugin flannel does not support config version "" plugin portmap does not support config version ""]

Answer

Edit file: /etc/cni/net.d/10-flannel.conflist

Adding “cniVersion”: “0.2.0” solved the issue.